libevent-2.1.12

Introduction à libevent

Libevent est une bibliothèque de notification d'événements asynchrones. L'API de libevent offre un mécanisme pour exécuter une fonction de secours si un événement spécifique se produit sur un descripteur de fichier ou après un certain délai. De plus, libevent supporte aussi les rappels de fonction issus de signaux ou de délais réguliers.

Ce paquet est connu pour se construire correctement sur une plateforme LFS-9.1.

Informations sur le paquet

Dépendances de libevent

Facultatives

Doxygen-1.8.18 (pour la documentation de l'API)

Notes utilisateur : http://wiki.linuxfromscratch.org/blfs/wiki/libevent

Installation de libevent

Installez libevent en lançant les commandes suivantes :

./configure --prefix=/usr --disable-static &&
make

Si vous avez installé Doxygen-1.8.18 et que vous souhaitez construire la documentation de l'API, lancez :

doxygen Doxyfile

Pour tester les résultats lancez : make verify.

Maintenant, en tant qu'utilisateur root :

make install

Si vous avez construit la documentation de l'API, installez-la en lançant les commandes suivantes en tant qu'utilisateur root :

install -v -m755 -d /usr/share/doc/libevent-2.1.12/api &&
cp      -v -R       doxygen/html/* \
                    /usr/share/doc/libevent-2.1.12/api

Explication des commandes

--disable-static : Ce paramètre empêche l'installation des versions statiques des bibliothèques.

Contenu

Programme installé: event_rpcgen.py
Bibliothèques installées: libevent_core.so, libevent_extra.so, libevent_openssl.so, libevent_pthreads.so et libevent.so
Répertoire installé: /usr/include/event2 et /usr/share/doc/libevent-2.1.12

Last updated on 2020-07-06 18:29:19 +0000