brotli-1.0.7

Introduction Brotli

Brotli fournit un algorithme de compression sans perte générique qui compresse des données avec une combinaison d'une variante moderne de l'algorithme LZ77, le codage de Huffman et la modélisation de contexte au second degré. Ses bibliothèques sont utilisées en particulier pour les polices WOFF2 sur le web.

Ce paquet est connu pour se construire correctement sur une plateforme LFS-9.1.

Informations sur le paquet

  • Tlchargement (HTTP) : https://github.com/google/brotli/archive/v1.0.7/brotli-v1.0.7.tar.gz

  • Tlchargement (FTP) :

  • Somme de contrle MD5 du tlchargement : 7b6edd4f2128f22794d0ca28c53898a5

  • Taille du tlchargement : 23 Mo

  • Estimation de l'espace disque requis : 43 Mo (plus 5 Mo si vous installez les deux ensembles de liaisons python, plus 9 Mo pour les tests principaux et 5 Mo pour tester les liaisons)

  • Estimation du temps de construction : 0.2 SBU (plus 0.3 SBU pour les liaisons python et 1.2 SBU si vous les testez)

Dpendances de Brotli

Requises

CMake-3.18.1

Facultatives

Python-2.7.18 (pour en créer les liaisons python2)

Notes utilisateur : http://wiki.linuxfromscratch.org/blfs/wiki/brotli

Installation de Brotli

Installez brotli en lanant les commandes suivantes :

mkdir out &&
cd    out &&

cmake -DCMAKE_INSTALL_PREFIX=/usr \
      -DCMAKE_BUILD_TYPE=Release  \
      ..  &&
make

Pour tester les rsultats lancez : make test.

Si vous le souhaitez, l'une ou les deux liaisons peuvent être construites et installées sans conflit. Si vous avez besoin des liaisons Python 2, ajoutez ou substituez python2 à la place de python3 dans les instructions suivantes :

pushd ..               &&
python3 setup.py build &&
popd

Si vous voulez tester les liaisons, retournez au répertoire de plus haut niveau et lancez python3 setup.py test.

Maintenant, en tant qu'utilisateur root :

make install &&
cd ..

Si vous avez construit l'un ou les deux ensembles de liaisons python, installez-les en tant qu'utilisateur root (comme avant, utilisez les versions appropriées de python) :

python3 setup.py install --optimize=1

Contents

Programmes installs: brotli
Bibliothques installes: libbrotlicommon{-static.a,.so}, libbrotlidec{,-static,.so} et libbrotlienc{,-static,.so}
Rpertoire install: /usr/include/brotli

Descriptions courtes

brotli

peut compresser ou décompresser des fichier ou tester l'intégrité des fichiers compressés.

libbrotlicommon{-static.a,.so}

est la bibliothèque pour le dictionnaire commun de Brotli.

libbrotlidec{-static.a,.so}

est la bibliothèque de décodage de Brotli.

libbrotlienc{-static.a,.so}

est la bibliothèque d'encodage commun de Brotli.

Last updated on 2020-06-30 22:01:54 +0000