GLib-2.64.4

Introduction à GLib

Le paquet GLib contient des bibliothèques de bas niveau utiles pour avoir la gestion de structures de données pour le C, des enveloppes de portabilité et des interfaces pour des fonctionnalités d'exécution telles qu'une boucle d'événements, les fils d'exécution, le chargement dynamique et un système d'objets.

Ce paquet est connu pour se construire correctement sur une plateforme LFS-9.1.

Informations sur le paquet

Téléchargements supplémentaires

Dépendances de GLib

Recommandées

Facultatives

dbus-1.12.20 et bindfs (tous deux utilisés dans quelques tests), GDB-9.2 (pour les liaisons), docbook-xml-4.5, docbook-xsl-1.79.2 et GTK-Doc-1.32 (pour construire la documentation de l'api)

Dépendances de Additional Runtime

Cité directement depuis le fichier INSTALL : « Certaines fonctionnalités de GIO liées aux types mime exigent update-mime-database et les outils update-desktop-database », qui font partie respectivement de shared-mime-info-2.0 et de desktop-file-utils-0.26. Ces deux utilitaires sont aussi requis pour certains tests.

Notes utilisateur : http://wiki.linuxfromscratch.org/blfs/wiki/glib2

Installation de GLib

Si vous le souhaitez, appliquez le correctif facultatif. Dans beaucoup de cas, les applications qui utilisent cette bibliothèque, directement ou indirectement via d'autres bibliothèques comme GTK+-3.24.21, affichent de nombreux avertissements lorsqu'ils sont lancés depuis la ligne de commande. Ce correctif permet d'utiliser une variable d'environnement, GLIB_LOG_LEVEL, qui supprime les messages non souhaités. La valeur de la variable est un nombre qui correspond à :

1 Alerte
2 Critique
3 Erreur
4 Avertissement
5 Remarque

Par exemple export GLIB_LOG_LEVEL=4 ignorera les sorties de messages d'avertissement et de remarque (et les messages Info/Debug s'ils sont activés). Si GLIB_LOG_LEVEL n'est pas défini, la sortie des messages normaux ne sera pas affectée.

patch -Np1 -i ../glib-2.64.4-skip_warnings-1.patch
[Avertissement]

Avertissement

Si vous mettez à jour depuis une version précédente de GLib qui a été construite avec les autotools, et que les archives libtool (les fichiers .la) ont été installées, vous devrez ajuster toutes les archives libtool, /usr/lib/libg{io,lib,module,object,thread}-2.0.la, en remplaçant les références aux archives libtool de ce paquet par le drapeau de l'éditeur de lien (-l) approprié, -lg{io,lib,module,object,thread}. Plus de 600 fichiers doivent être modifiés sur un bureau gnome complet.

Autrement, vous pouvez simplement supprimer les fichiers .la inutiles avec le script de Libtool archive (.la) files.

Installez GLib en lançant les commandes suivantes :

mkdir build &&
cd    build &&

meson --prefix=/usr      \
      -Dman=true         \
      -Dselinux=disabled \
      ..                 &&
ninja
[Note]

Note

Si libxslt-1.1.34 est installé, la commande suivante peut indiquer plusieurs erreurs (environ 33) qui commencent par « Error: no ID for constraint linkend: » lors de l'installation des pages de manuel. Elles sont inoffensives.

La suite de tests de GLib exige desktop-file-utils pour quelques tests. Cependant, desktop-file-utils exige GLib pour se compiler ; vous devrez donc installer d'abord GLib puis lancer la suite de test.

Maintenant, en tant qu'utilisateur root :

ninja install &&

mkdir -p /usr/share/doc/glib-2.64.4 &&
cp -r ../docs/reference/{NEWS,gio,glib,gobject} /usr/share/doc/glib-2.64.4

Vous devriez maintenant installer desktop-file-utils-0.26 et shared-mime-info-2.0 et lancer la suite de tests.

Pour tester les résultats, après avoir installé le paquet, lancez : ninja test.

Explication des commandes

-Dman=true : Ce paramètre cause la construction et l'installation des pages de manuel du paquet.

-Dselinux=disabled : Ce paramètre désactive le support de selinux qui n'est pas supporté par BLFS.

-Ddocs=true : Ce paramètre cause la construction et l'installation de la documentation de l'API.

Contenu

Programmes installés: gapplication, gdbus, gdbus-codegen, gio, gio-querymodules, glib-compile-resources, glib-compile-schemas, glib-genmarshal, glib-gettextize, glib-mkenums, gobject-query, gresource, gsettings, gtester et gtester-report
Bibliothèques installées: libgio-2.0.so, libglib-2.0.so, libgmodule-2.0.so, libgobject-2.0.so et libgthread-2.0.so
Répertoires installés: /usr/include/gio-unix-2.0, /usr/include/glib-2.0, /usr/lib/glib-2.0, /usr/share/glib-2.0 et /usr/share/gtk-doc/html/{gio,glib,gobject}

Descriptions courtes

gapplication

peut être utilisé pour démarrer des applications et pour envoyer des messages aux instances déjà lancées d'autres applications.

gdbus

est un outil simple utilisé pour fonctionner avec des objets D-Bus.

gdbus-codegen

est utilisé pour générer du code et de la documentation pour une ou plusieurs interfaces D-Bus.

gio

est un utilitaire qui rend plusieurs fonctionnalités de GIO disponibles depuis la ligne de commande.

gio-querymodules

est utilisé pour créer un fichier giomodule.cache dans les répertoires listés. Ce fichier liste les points d'extension implémentés pour chaque module trouvé.

glib-compile-resources

est utilisé pour lire la description des ressources à partir d'un fichier et des fichiers référencés pour créer un catalogue de ressources binaire adapté à une utilisation avec l'API GResource.

glib-compile-schemas

est utilisé pour compiler tous les fichiers de schémas XML de GSettings du répertoire en un fichier binaire nommé gschemas.compiled utilisable par GSettings.

glib-genmarshal

est un outil de génération marshaller de code C pour les closures GLib.

glib-gettextize

est une variante de l'outil d'internationalisation gettext.

glib-mkenums

est un outil de génération de description des enum du langage C.

gobject-query

est un outil qui dessine une arborescence de types.

gresource

offre une interface simple en ligne de commande avec GResource.

gsettings

offre une interface simple en ligne de commande avec GSettings.

gtester

est un outil d'exécution de tests.

gtester-report

est un outil de formatage de rapports de test.

Bibliothèques GLib

contient une bibliothèque cœur de bas niveau pour le Toolkit GIMP.

Last updated on 2020-07-02 18:10:38 +0000