libcroco-0.6.13

Introduction à libcroco

Le paquet libcroco contient la bibliothèque de manipulation et d'analyse CSS2 autonome.

Ce paquet est connu pour se construire correctement sur une plateforme LFS-9.1.

Informations sur le paquet

Dépendances de libcroco

Requises

GLib-2.64.0 et libxml2-2.9.10

Facultatives

GTK-Doc-1.32

Notes utilisateur : http://wiki.linuxfromscratch.org/blfs/wiki/libcroco

Installation de libcroco

Installez libcroco en lançant les commandes suivantes :

./configure --prefix=/usr --disable-static &&
make

Pour lancer la suite de tests, exécutez make -k test. Certains tests échouent : la recherche de fichiers se fait au mauvais endroit, des problèmes de locale (des codes de caractère sont comparés aux caractères), des nombres décimaux pas correctement arrondis au même nombre sont quelques unes des raisons.

Maintenant, en tant qu'utilisateur root :

make install

Explication des commandes

--disable-static : Ce paramètre empêche l'installation des versions statiques des bibliothèques.

--enable-gtk-doc : Utilisez ce paramètre si GTK-Doc est installé et si vous souhaitez reconstruire et installer la documentation de l'API.

Contenu

Programmes installés: croco-0.6-config et csslint-0.6
Bibliothèque installée: libcroco-0.6.so
Répertoires installés: /usr/include/libcroco-0.6 et /usr/share/gtk-doc/html/libcroco

Descriptions courtes

croco-0.6-config

est un script d'aide pour construire avec libcroco-0.6.so.

csslint-0.6

est utilisé pour analyser un ou plusieurs fichiers CSS spécifiés sur la ligne de commande.

libcroco-0.6.so

contient les fonctions de l'API d'analyse et de manipulation CSS2.

Last updated on 2020-02-16 23:15:05 +0000