libgpg-error-1.38

Introduction à libgpg-error

Le paquet libgpg-error contient une bibliothèque qui définit les valeurs habituelles d'erreur pour tous les composants de GnuPG.

Ce paquet est connu pour se construire correctement sur une plateforme LFS-9.1.

Informations sur le paquet

Notes utilisateur : http://wiki.linuxfromscratch.org/blfs/wiki/libgpg-error

Installation de libgpg-error

Installez libgpg-error en lançant les commandes suivantes :

./configure --prefix=/usr &&
make

Pour tester les résultats lancez : make check.

Maintenant, en tant qu'utilisateur root :

make install &&
install -v -m644 -D README /usr/share/doc/libgpg-error-1.38/README

Contenu

Programmes installés: gpg-error, gpg-error-config, gpgrt-config et yat2m
Bibliothèque installée: libgpg-error.so
Répertoires installés: /usr/share/common-lisp/source/gpg-error, /usr/share/libgpg-error et /usr/share/doc/libgpg-error-1.38

Descriptions courtes

gpg-error

est utilisé pour déterminer les codes d'erreur de libgpg-error.

gpg-error-config

est un outil utilisé pour configurer et construire des applications basées sur la bibliothèque libgpg-error. Il peut être utilisé pour interroger le compilateur C et les drapeaux de l'éditeur de liens qui sont nécessaires pour compiler et éditer correctement les liens de l'application à la bibliothèque libgpg-error.

gpgrt-config

est le même script que gpg-error-config

yat2m

extrait les pages de manuel d'une source Texinfo.

libgpg-error.so

contient les fonctions de l'API libgpg-error.

Last updated on 2020-05-30 23:17:54 +0000