libgudev-233

Introduction à libgudev

Le paquet libgudev contient les liaisons GObject pour libudev.

Ce paquet est connu pour se construire correctement sur une plateforme LFS-9.1.

Informations sur le paquet

Requises

GLib-2.64.4

Facultatives

gobject-introspection-1.64.1 (pour gir-data, utilisé par GNOME), GTK-Doc-1.32 et umockdev-0.14.2 (pour les tests)

Notes utilisateur : http://wiki.linuxfromscratch.org/blfs/wiki/libgudev

Installation de libgudev

Installez libgudev en lançant les commandes suivantes :

./configure --prefix=/usr --disable-umockdev &&
make

Si vous voulez lancer la suite de tests, n'indiquez pas « --disable-umockdev » sur la ligne de commande de configure et lancez : make check.

Maintenant, en tant qu'utilisateur root :

make install

Explication des commandes

--enable-gtk-doc : Utilisez ce paramètre si GTK-Doc est installé et si vous souhaitez reconstruire et installer la documentation de l'API.

--disable-umockdev : désactive l'utilisation de umockdev-0.14.2. Ne l'utilisez pas si vous voulez lancer la suite de tests.

Contenu

Programme installé: Aucun
Bibliothèques installées: libgudev-1.0.so
Répertoires installés: /usr/include/gudev-1.0 et /usr/share/gtk-doc/html/gudev

Descriptions courtes

libgudev-1.0.so

est une bibliothèque enveloppe basée sur GObject pour libudev.

Last updated on 2020-04-02 18:07:58 +0000