Popt-1.18

Introduction à Popt

Le paquet popt contient les bibliothèques popt qui sont utilisées par certains programmes pour analyser des options en ligne de commande.

Ce paquet est connu pour se construire correctement sur une plateforme LFS-9.1.

Informations sur le paquet

Notes utilisateur : http://wiki.linuxfromscratch.org/blfs/wiki/popt

Installation de Popt

Installez popt en lançant les commandes suivantes :

./configure --prefix=/usr --disable-static &&
make

Si vous avez installé Doxygen-1.8.18 et si vous souhaitez construire la documentation de l'API, exécutez :

sed -i 's@\./@src/@' Doxyfile &&
doxygen

Pour tester les résultats lancez : make check.

Maintenant, en tant qu'utilisateur root :

make install

Si vous avez construit la documentation de l'API, installez-la en utilisant les commandes suivantes exécutées par l'utilisateur root :

install -v -m755 -d /usr/share/doc/popt-1.18 &&
install -v -m644 doxygen/html/* /usr/share/doc/popt-1.18

Explication des commandes

--disable-static : Ce paramètre empêche l'installation des versions statiques des bibliothèques.

Contenu

Programmes installés: Aucun
Bibliothèque installée: libpopt.so
Répertoires installés: /usr/share/doc/popt-1.18

Descriptions courtes

libpopt.so

est utilisé pour analyser les options en ligne de commande.

Last updated on 2020-06-25 16:34:03 +0000