libsecret-0.20.3

Introduction à libsecret

Le paquet libsecret contient une bibliothèque basée sur GObject pour accéder à l'API Secret Service.

Ce paquet est connu pour se construire correctement sur une plateforme LFS-9.1.

Informations sur le paquet

Dépendances de libsecret

Requises

GLib-2.64.4

Recommandées

Facultatives

GTK-Doc-1.32 et docbook-xml-4.5, docbook-xsl-1.79.2, libxslt-1.1.34 (pour construire les pages de manuel) et Valgrind-3.16.1 (peut être utilisé dans les tests)

Facultative (Requis pour la suite de tests)

D-Bus Python-1.2.16, Gjs-1.64.4, et PyGObject-3.36.1 (module Python 3)

Dépendances d'exécution

gnome-keyring-3.36.0

[Note]

Note

Tous les paquets demandant libsecret s'attendent à ce que GNOME Keyring soit présent à l'exécution.

Notes utilisateur : http://wiki.linuxfromscratch.org/blfs/wiki/libsecret

Installation de libsecret

Installez libsecret en lançant les commandes suivantes :

mkdir bld &&
cd bld &&

meson --prefix=/usr -Dgtk_doc=false .. &&
ninja

Maintenant, en tant qu'utilisateur root :

ninja install

Pour tester les résultats, tapez : ninja test, après l'installation du paquet. La suite de tests doit être lancée depuis une session GUI locale démarrée avec dbus-launch.

Explication des commandes

-Dgtk_doc=false : Supprimez ceci si vous avez installé GTK-Doc-1.32 et souhaitez reconstruire la documentation avec.

-Dmanpage=false : Utilisez ce paramètre si vous n'avez pas installé libxslt-1.1.34 et les paquets DocBook.

-Dgcrypt=false : Utilisez ce paramètre si vous n'avez pas installé la dépendance recommandée de libgcrypt-1.8.6.

Contenu

Programme installé: secret-tool
Bibliothèque installée: libsecret-1.so
Répertoires installés: /usr/include/libsecret-1 et /usr/share/gtk-doc/html/libsecret-1

Descriptions courtes

secret-tool

est un outil en ligne de commande qui peut être utilisé pour enregistrer ou lire des mots de passe.

libsecret-1.so

Contient les fonctions de l'API de libsecret

Last updated on 2020-04-15 21:55:55 +0000