network-manager-applet-1.8.24

Introduction à NetworkManager Applet

NetworkManager Applet fournit un outil et un applet utilisé pour configurer les connexions filaires et sans fils depuis une interface graphique. Il est conçu pour être utilisé avec n'importe quel environnement de bureau utilisant GTK+ comme Xfce et LXDE.

Ce paquet est connu pour se construire correctement sur une plateforme LFS-9.1.

Informations sur le paquet

Dépendances de NetworkManager Applet

Requises

Gcr-3.34.0, GTK+-3.24.14, ISO Codes-4.4, libsecret-0.20.1, libnotify-0.7.9 et NetworkManager-1.22.10

Recommandées

Requises (Exécution)

comme ce paquet utilise Polkit-0.116 pour les accès, un Polkit Authentication Agent doit être lancé pour pouvoir utiliser les fonctionnalités de ce paquet.

Facultatives

gnome-bluetooth-3.34.0, GTK-Doc-1.32, jansson-2.12, libindicator et mobile-broadband-provider-info (à l'exécution)

Notes utilisateur : http://wiki.linuxfromscratch.org/blfs/wiki/network-manager-applet

Installation de NetworkManager Applet

Installez NetworkManager Applet en lançant les commandes suivantes :

mkdir build &&
cd    build &&

meson --prefix=/usr     \
      --sysconfdir=/etc \
      -Dselinux=false   \
      -Dteam=false      \
      -Dmobile_broadband_provider_info=false \
      -Dgtk_doc=false .. &&
ninja

Pour tester les résultats lancez : ninja test.

Maintenant, en tant qu'utilisateur root :

ninja install

Explication des commandes

-Dteam=false : Ce paramètre désactive l'éditeur de configuration team car il requiert jansson-2.12. Si vous avez installé Jansson, supprimez cette option ou mettez-la à « true ».

-Dselinux=false : Ce paramètre force la désactivation du support pour SELinux car il n'est actuellement pas dans BLFS et la construction échoue sans lui.

-Dmobile_broadband_provider_info=false : Ce paramètre force la désactivation du support pour Mobile Broadband Provider qui n'est actuellement pas disponible dans BLFS.

-Dgtk_doc=false : Supprimez cela si vous avez installé GTK-Doc-1.32 et souhaitez reconstruire la documentation avec lui.

-Dwwan=false : Ce paramètre désactive le support de WWAN. Utilisez-le si vous n'avez pas installé ModemManager-1.12.8.

-Dintrospection=false : Utilisez cela si vous n'avez pas installé gobject-introspection-1.64.0.

Contenu

Programmes installés: nm-applet et nm-connection-editor
Bibliothèques installées: libnma.so
Répertoires installés: /usr/include/libnma et /usr/share/gtk-doc/libnma

Descriptions courtes

nm-connection-editor

autorise les utilisateurs à voir et éditer les paramètres des connexions réseaux.

libnma.so

contient les fonctions internes des interfaces GTK+ à Network Manager.

Last updated on 2020-02-27 06:00:52 +0000