VTE-0.60.3

Introduction à VTE

Le paquet VTE contient une implémentation du fichier termcap pour les émulateurs de terminal.

Ce paquet est connu pour se construire correctement sur une plateforme LFS-9.1.

Informations sur le paquet

Dépendances de VTE

Requises

GTK+-3.24.21, libxml2-2.9.10 et pcre2-10.35

Recommandées

Facultatives

FriBidi-1.0.9, GTK-Doc-1.32 et GTK+-4

Notes utilisateur : http://wiki.linuxfromscratch.org/blfs/wiki/vte

Installation de VTE

Installez VTE en lançant les commandes suivantes :

mkdir build &&
cd    build &&

meson  --prefix=/usr --sysconfdir=/etc -Dfribidi=false &&
ninja 

Pour tester les résultats lancez : ninja test.

Maintenant, en tant qu'utilisateur root :

ninja install &&
rm -v /etc/profile.d/vte.*

Explication des commandes

rm -v /etc/profile.d/vte.* : cette commande supprime deux fichiers installés dans /etc/profile.d qui n'ont aucune utilité dans un système LFS.

-Dfribidi=false : n'utilisez pas ce paramètre si vous voulez activer la prise en charge du texte bidirectionnel.

-Dgnutls=false : ajoutez ce paramètre si vous ne voulez pas activer la prise en charge de GNUTLS.

-Dvapi=false : ajoutez ce paramètre si vous ne voulez pas activer les liaisons vala.

-Ddocs=true : ajoutez ce paramètre si vous voulez construire la documentation.

Contenu

Programme installé: vte-2.91
Bibliothèque installée: libvte-2.91.so
Répertoires installés: /usr/include/vte-2.91 et /usr/share/gtk-doc/html/vte-2.91

Descriptions courtes

vte-2.91

est une application de test pour les bibliothèques VTE.

libvte-2.91.so

est une bibliothèque qui implémente un widget d'émulateur de terminal pour GTK GTK+ 3.

Last updated on 2020-05-30 11:54:15 +0000