Polkit-Qt-0.113.0

Introduction à Polkit-Qt

Polkit-Qt fournit une API à PolicyKit dans l'environnement Qt.

Ce paquet est connu pour se construire correctement sur une plateforme LFS-9.1.

Informations sur le paquet

Dépendances de Polkit-Qt

Requises

CMake-3.18.1, Polkit-0.117 et Qt-5.15.0

Notes utilisateur : http://wiki.linuxfromscratch.org/blfs/wiki/polkit-qt

Installation de Polkit-Qt

Installez Polkit-Qt en lançant les commandes suivantes :

mkdir build &&
cd    build &&

cmake -DCMAKE_INSTALL_PREFIX=/usr \
      -DCMAKE_BUILD_TYPE=Release  \
      -Wno-dev .. &&
make

Ce paquet n'est pas fourni avec une suite de tests.

Maintenant, en tant qu'utilisateur root :

make install

Explication des commandes

-DCMAKE_BUILD_TYPE=Release : Ce paramètre est utilisé pour appliquer un plus haut niveau d'optimisation du compilateur.

Contenu

Programmes installés: aucun
Bibliothèques installées: libpolkit-qt5-agent-1.so, libpolkit-qt5-core-1.so et libpolkit-qt5-gui-1.so
Répertoires installés: /usr/include/polkit-qt5-1 et /usr/lib/cmake/PolkitQt5-1

Last updated on 2020-05-15 17:28:31 +0000