Vte-0.28.2

Introduction à Vte

Vte est une bibliothèque (libvte) qui implémente un widget d'émulateur de terminal pour GTK+ 2, et une application de démonstration minimale (vte) qui utilise libvte.

Ce paquet est connu pour se construire correctement sur une plateforme LFS-9.1.

Informations sur le paquet

Dépendances de Vte

Requises

GTK+-2.24.32

Facultatives

gobject-introspection-1.64.1, GTK-Doc-1.32 et PyGTK-2.24.0

Notes utilisateur : http://wiki.linuxfromscratch.org/blfs/wiki/vte2

Installation de Vte

Installez Vte en lançant les commandes suivantes :

./configure --prefix=/usr \
            --libexecdir=/usr/lib/vte \
            --disable-static  &&
make

Pour tester les résultats lancez : make check.

Maintenant, en tant qu'utilisateur root :

make install

Explication des commandes

--libexecdir=/usr/lib/vte : ce paquet et VTE-0.60.3 installent des fichiers qui ont le même nom. Ce paramètre s'assure qu'ils ne se réécriront pas l'un l'autre s'ils sont tous les deux installés.

--disable-static : Ce paramètre empêche l'installation des versions statiques des bibliothèques.

Contents

Programme installé: vte
Bibliothèque installée: libvte.so
Répertoires installés: /usr/include/vte-0.0, /usr/lib/vte, /usr/share/gtk-doc/html/vte-0.0 et /usr/share/vte

Descriptions courtes

vte

est un émulateur de terminal simple.

libvte.so

Contient les fonctions de l'API de Vte

Last updated on 2020-02-17 20:12:55 +0000