Audacious-4.0.5

Introduction à Audacious

Audacious est un lecteur audio.

Ce paquet est connu pour se construire correctement sur une plateforme LFS-9.1.

Informations sur le paquet

  • Téléchargement (HTTP) : https://distfiles.audacious-media-player.org/audacious-4.0.5.tar.bz2

  • Téléchargement (FTP) :

  • Somme de contrôle MD5 du téléchargement : a2e8420ce841cb18ff380d7ad0185651

  • Taille du téléchargement : 564 Ko

  • Estimation de l'espace disque requis : 59 Mo (avec l'interface Qt)

  • Estimation du temps de construction : 0,6 SBU (avec l'interface Qt)

Téléchargements supplémentaires

Module externe nécessaire

Dépendances de Audacious

Requises

GTK+-2.24.32 ou Qt-5.15.0 (ou les deux), libxml2-2.9.10 (greffons), Environnement de construction de Xorg (greffons), et Système X Window (exécution)

Recommandées

ALSA-1.2.2 et dbus-1.12.20, aussi gnome-icon-theme-3.12.0 (exécution)

Facultatives

Valgrind-3.16.1

Recommandé (pour les greffons)

Facultatives (pour les greffons)

cURL-7.71.1, FAAD2-2_9_2, FFmpeg-4.3.1, FLAC-1.3.3, LAME-3.100, libcdio-2.1.0 (pour identifier et jouer des CD), libnotify-0.7.9, libsamplerate-0.1.9, libsndfile-1.0.28, libvorbis-1.3.7, PulseAudio-13.0, SDL-1.2.15, adplug, La bibliothèque Bauer stereophonic-to-binaural DSP (bs2b), FluidSynth, JACK (requiert libsamplerate-0.1.9), libcue, libmodplug, libmms, libsidplayfp, LIRC et WavPack

Notes utilisateur : http://wiki.linuxfromscratch.org/blfs/wiki/audacious

Installation de Audacious

Installation de the Main Audacious Program

Installez Audacious en lançant les commandes suivantes (vous pourriez vouloir changer le tampon par une autre chaîne) :

TPUT=/bin/true ./configure --prefix=/usr \
                           --with-buildstamp="BLFS" &&
make

Ce paquet n'est pas fourni avec une suite de tests.

Maintenant, en tant qu'utilisateur root :

make install

Installation de Audacious Plugins

Installez les greffons requis en lançant les commandes suivantes :

tar -xf ../audacious-plugins-4.0.5.tar.bz2                &&
cd audacious-plugins-4.0.5                                &&
TPUT=/bin/true ./configure --prefix=/usr --disable-wavpack &&
make

Maintenant, en tant qu'utilisateur root :

make install
[Note]

Note

Ce paquet installe des fichiers d'icônes dans la hiérarchie /usr/share/icons/hicolor et des fichiers du bureau dans la hiérarchie /usr/share/applications. Vous pouvez améliorer les performances du système et l'utilisation de la mémoire en mettant à jour /usr/share/icons/hicolor/index.theme et /usr/share/applications/mimeinfo.cache. Pour réaliser la mise à jour vous devez avoir installé GTK+-2.24.32 ou GTK+-3.24.22 (pour le cache des icônes) et desktop-file-utils-0.26 (pour le cache du bureau) et taper la commande suivante en tant qu'utilisateur root :

gtk-update-icon-cache -qtf /usr/share/icons/hicolor &&
update-desktop-database -q

Explication des commandes

TPUT=/bin/true : le réglage par défaut fait en sorte que make affiche le texte en couleur. Ceci est parfait si vous construisez dans un terminal, mais si vous scriptez le processus de construction et si vous pipez la sortie de make vers un fichier journal, les caractères de contrôle utilisés pour colorer le texte peuvent rendre le fichier journal illisible. Cette option désactive la coloration du texte.

--with-buildstamp : Ce paramètre ajoute le texte donné à la chaine de version.

--disable-wavpack : Ce paramètre est requis à moins que le paquet WavPack ne soit installé.

--enable-gtk : Utilisez ce paramètre pour activer la prise en charge de GTK+.

--disable-qt : Utilisez ce paramètre pour désactiver le support de qt

--disable-mp3 : Utilisez ce paramètre pour les greffons si vous n'avez pas installé mpg123 et ne souhaitez pas jouer des fichiers mp3.

--enable-valgrind : Permet de meilleurs vérifications de fuite avec Valgrind.

--disable-neon : Utilisez ce paramètre pour les greffons si vous n'avez pas installé neon et ne souhaitez pas utiliser le transport HTTP/HTTPS.

Configuration de Audacious

Si vous préférez l'ancienne interface Winamp/XMMS, plus petite, Cliquez sur View> (vues) Interface> Winamp Classic Interface (interface classique Winamp).

Si vous construisez avec les deux interfaces utilisateur Gtk et Qt, la version Qt peut être exécutée depuis un terminal, en tapant audacious --qt. Si vous souhaitez une entrée de menu dans votre bureau pour exécuter la version Qt, tapez les commandes suivantes en tant qu'utilisateur root :

cp -v /usr/share/applications/audacious{,-qt}.desktop &&

sed -e '/^Name/ s/$/ Qt/' \
    -e '/Exec=/ s/audacious/& --qt/' \
    -i /usr/share/applications/audacious-qt.desktop

Contenu

Programmes installés: audacious et audtool
Bibliothèques installées: libaudcore.so, libaudqt.so, libaudtag.so et divers bibliothèques de greffons dans /usr/lib/audacious/ sub-directories
Répertoires installés: /usr/include/{audacious,libaudcore,libaudqt}, /usr/lib/audacious and /usr/share/audacious

Descriptions courtes

audacious

est un port Qt de XMMS basé sur le lecteur Beep Media Player.

audtool

est un petit outil pour modifier le comportement d'une instance audacious.

Last updated on 2020-07-11 16:36:30 +0000