Nettle-3.6

Introduction à Nettle

Le paquet Nettle contient une bibliothèque cryptographique de bas niveau conçue pour facilement s'adapter à divers contextes.

Ce paquet est connu pour se construire correctement sur une plateforme LFS-9.1.

Informations sur le paquet

Notes utilisateur : http://wiki.linuxfromscratch.org/blfs/wiki/nettle

Installation de Nettle

Installez Nettle en lançant les commandes suivantes :

./configure --prefix=/usr --disable-static &&
make

Pour tester les résultats lancez : make check.

Maintenant, en tant qu'utilisateur root :

make install &&
chmod   -v   755 /usr/lib/lib{hogweed,nettle}.so &&
install -v -m755 -d /usr/share/doc/nettle-3.6 &&
install -v -m644 nettle.html /usr/share/doc/nettle-3.6

Explication des commandes

--disable-static : Ce paramètre empêche l'installation des versions statiques des bibliothèques.

Contenu

Programmes installés: nettle-hash, nettle-lfib-stream, nettle-pbkdf2, pkcs1-conv et sexp-conv
Bibliothèques installées: libhogweed.so et libnettle.so
Répertoire installé: /usr/include/nettle et /usr/share/doc/nettle-3.6

Descriptions courtes

nettle-hash

calcule une valeur hachée en utilisant l'algorithme spécifié.

nettle-lfib-stream

sort une séquence d'octets pseudo-aléatoires (non cryptographiques), en utilisant le générateur fibonacci contenu de Knuth. Le flux est utile pour du test, mais vous ne devriez pas l'utiliser pour générer des clés de chiffrement ou quoique ce soit qui nécessite du vrai aléatoire.

nettle-pbkdf2

fonction de dérivation basée sur un mot de passe qui prend en entrée un mot de passe ou une phrase de passe et la teste et la protège contre des attaques pré-calculées en utilisant des calculs très coûteux et salés.

pkcs1-conv

convertit des clés RSA privées et publiques du format PKCS #1 en format sexp.

sexp-conv

convertit une s-expression en un autre encodage.

Last updated on 2020-05-03 04:16:49 +0000