at-spi2-atk-2.34.2

Introduction à At-Spi2 Atk

Le paquet At-Spi2 Atk contient une bibliothèque qui relie ATK au service D-Bus At-Spi2.

Ce paquet est connu pour se construire correctement sur une plateforme LFS-9.1.

Informations sur le paquet

Dépendances de At-Spi2 Atk

Requises

at-spi2-core-2.36.0 et ATK-2.36.0

Notes utilisateur : http://wiki.linuxfromscratch.org/blfs/wiki/at-spi2-atk

Installation de At-Spi2 Atk

Installez At-Spi2 Atk en lançant les commandes suivantes :

mkdir build &&
cd build &&

meson --prefix=/usr .. &&
ninja

Pour tester les résultats, tapez : ninja test. Une session graphique active avec l'adresse de bus est nécessaire pour lancer les tests.

Maintenant, en tant qu'utilisateur root :

ninja install
[Note]

Note

Si vous installé le paquet dans votre système en utilisant une méthode « DESTDIR », /usr/share/glib-2.0/schemas/gschemas.compiled n'a pas été mis à jour/créé. Créez (ou mettez à jour) le fichier en utilisant la commande suivante en tant qu'utilisateur root :

glib-compile-schemas /usr/share/glib-2.0/schemas

Contenu

Programmes installés: Aucun
Bibliothèques installées: libatk-bridge-2.0.so et /usr/lib/gtk-2.0/modules/libatk-bridge.so
Répertoire installé: /usr/include/at-spi2-atk and /usr/lib/gnome-settings-daemon-3.0

Descriptions courtes

libatk-bridge.so

est le module GTK+ du toolkit accessibilité.

libatk-bridge-2.0.so

Contient les fonctions standards utilisées par le pont d'outils d'accessibilité GTK+.

Last updated on 2020-03-02 02:36:41 +0000