at-spi2-core-2.36.0

Introduction à At-Spi2 Core

Le paquet At-Spi2 Core fait partie du projet accessibilité de GNOME. Il offre une interface fournisseur de service aux technologies d'assistance disponibles sur la plate-forme GNOME et aux bibliothèques auxquelles peuvent se lier les applications.

Ce paquet est connu pour se construire correctement sur une plateforme LFS-9.1.

Informations sur le paquet

Dépendances de At-Spi2 Core

Requises

dbus-1.12.20, GLib-2.64.4 et Bibliothèques Xorg

Facultative (requise pour la construction de GNOME)

gobject-introspection-1.64.1

Facultatives

GTK-Doc-1.32

Notes utilisateur : http://wiki.linuxfromscratch.org/blfs/wiki/at-spi2-core

Installation de At-Spi2 Core

Installez At-Spi2 Core en lançant les commandes suivantes :

mkdir build &&
cd    build &&

meson --prefix=/usr     \
      --sysconfdir=/etc \
      -Dsystemd_user_dir=/tmp .. &&
ninja

Une adresse de bus de session, normalement disponible dans un terminal Xorg, est nécessaire pour lancer les tests. Pour tester le résultat, tapez : ninja test. Le test mémoire est connu pour dépasser le délai d'attente.

Maintenant, en tant qu'utilisateur root :

ninja install &&
rm /tmp/at-spi-dbus-bus.service

Explication des commandes

-Dsystemd_user_dir=/tmp : Ce drapeau installe le fichier d'unité de systemd dans /tmp où il sera supprimé. SysV ne peut pas utiliser ce fichier.

Contenu

Programmes installés: Aucun
Bibliothèque installée: libatspi.so
Répertoires installés: /usr/include/at-spi-2.0, /usr/share/defaults/at-spi2 et /usr/share/gtk-doc/html/libatspi

Descriptions courtes

libatspi.so

contient les fonctions de l'API de At-Spi2.

Last updated on 2020-03-10 00:51:37 +0000