Gtkmm-2.24.5

Introduction à Gtkmm

Le paquet Gtkmm fournit une interface C++ avec GTK+-2. On peut l'installer avec Gtkmm-3.24.2 (la bibliothèque GTK+-3) sans conflit de noms.

Ce paquet est connu pour se construire correctement sur une plateforme LFS-9.1.

Informations sur le paquet

Dépendances de Gtkmm

Requises

Atkmm-2.28.0, GTK+-2.24.32 et Pangomm-2.42.1

Notes utilisateur : http://wiki.linuxfromscratch.org/blfs/wiki/gtkmm2

Installation de Gtkmm

Pour commencer, corrigez le nom du répertoire de documentation:

sed -e '/^libdocdir =/ s/$(book_name)/gtkmm-2.24.5/' \
    -i docs/Makefile.in

Installez Gtkmm en lançant les commandes suivantes :

./configure --prefix=/usr &&
make

Pour tester les résultats lancez : make check.

Maintenant, en tant qu'utilisateur root :

make install

Contenu

Programmes installés: Aucun
Bibliothèques installées: libgdkmm-2.4.so et libgtkmm-2.4.so.
Répertoires installés: /usr/include/gdkmm-2.4, /usr/include/gtkmm-2.4, /usr/lib/gdkmm-2.4, /usr/lib/gtkmm-2.4, et /usr/share/{devhelp/books/gtkmm-2.4,doc/gtkmm-2.24.5}

Descriptions courtes

libgdkmm-2.4.so

contient les classes de L'API de GDK.

libgtkmm-2.4.so

contient les classes de l'API de GTK+

Last updated on 2020-02-18 22:50:03 +0000