libglade-2.6.4

Introduction à libglade

Le paquet libglade contient les bibliothèques libglade. Elles sont utiles pour le chargement de fichiers d'interface Glade dans un programme en cours d'exécution.

Ce paquet est connu pour se construire correctement sur une plateforme LFS-9.1.

Informations sur le paquet

Dépendances de libglade

Requises

libxml2-2.9.10 et GTK+-2.24.32

Facultatives

Python-2.7.18 et GTK-Doc-1.32

Notes utilisateur : http://wiki.linuxfromscratch.org/blfs/wiki/libglade

Installation de libglade

Installez libglade en lançant les commandes suivantes :

sed -i '/DG_DISABLE_DEPRECATED/d' glade/Makefile.in &&
./configure --prefix=/usr --disable-static &&
make

Pour tester les résultats, lancez : make check. Un des tests, test-convert, est connu pour échouer.

Maintenant, en tant qu'utilisateur root :

make install

Explication des commandes

sed -i '/DG_DISABLE_DEPRECATED/d' : Certaines fonctions de glib utilisées par libglade ont été déclarées obsolètes dans glib-2.30. Ce sed supprime G_DISABLE_DEPRECATED CFLAG.

--disable-static : Ce paramètre empêche l'installation des versions statiques des bibliothèques.

--enable-gtk-doc : Utilisez ce paramètre si GTK-Doc est installé et si vous souhaitez reconstruire et installer la documentation de l'API.

Contenu

Programme installé: libglade-convert (requiert python)
Bibliothèque installée: libglade-2.0.so
Répertoires installés: /usr/{include/libglade-2.0/glade,share/{gtk-doc/html/libglade, xml/libglade}}

Descriptions courtes

libglade-convert

est utilisé pour convertir de vieux fichiers d'interface Glade en standards Glade-2.0.

libglade-2.0.so

contient les fonctions nécessaires pour charger les fichiers d'interface Glade.

Last updated on 2020-03-21 11:42:20 +0000