Pidgin-2.14.1

Introduction à Pidgin

Pidgin est un client de messagerie instantanée Gtk+-2 qui peut se connecter à une grande variété de réseaux, notamment AIM, ICQ, GroupWise, MSN, Jabber, IRC, Napster, Gadu-Gadu, SILC, Zephyr et Yahoo!.

Ce paquet est connu pour se construire correctement sur une plateforme LFS-9.1.

Informations sur le paquet

  • Téléchargement (HTTP) : https://downloads.sourceforge.net/pidgin/pidgin-2.14.1.tar.bz2

  • Téléchargement (FTP) :

  • Somme de contrôle MD5 du téléchargement : e135798bcf952ddb3c9e030c4b160c3e

  • Taille du téléchargement : 8.4 Mo

  • Estimation de l'espace disque requis : 277 Mo (avec les tests et la doc)

  • Estimation du temps de construction : 0,7 SBU (avec parallélisme = 4 ; avec les tests et la doc)

Dépendances de Pidgin

Requises

GTK+-2.24.32

Recommandées

Le support SSL est requis pour les plugins des protocoles MSN Messenger, Yahoo!, Novel Groupwise et Google Talk. GnuTLS est préférable (l'API Mozilla nss est plus susceptible de changer et cela peut être la cause de problèmes).

Facultatives

Avahi-0.8 (requis pour le greffon Bonjour), Cyrus SASL-2.1.27, dbus-1.12.20, evolution-data-server-3.36.5, GConf-3.2.6, libidn-1.36 (requis, si vous voulez lancer la suite de tests), NetworkManager-1.26.0, SQLite-3.32.3 (requis pour le greffon Contact Availability Prediction), startup-notification-0.12, Tk-8.6.10, Farstream (Version 0.1) (requis pour la prise en charge de la vidéo et de la voix), Gtkspell, libgadu, Meanwhile (requis pour le support du protocole Sametime), Mono, SILC Client, SILC Toolkit, Zephyr et MIT Kerberos V5-1.18.2 (requis pour le support de Kerberos dans le greffon Zephyr)

Facultatives (exécution)

xdg-utils-1.1.3

Notes utilisateur : http://wiki.linuxfromscratch.org/blfs/wiki/pidgin

Installation de Pidgin

Si vous souhaitez lancer la suite de tests, soyez certain que libidn-1.36 est installé et enlevez le paramètre « --disable-idn ». Compilez Pidgin en lançant les commandes suivantes :

./configure --prefix=/usr        \
            --sysconfdir=/etc    \
            --disable-gstreamer  \
            --disable-avahi      \
            --disable-gtkspell   \
            --disable-meanwhile  \
            --disable-idn        \
            --disable-nm         \
            --disable-vv         &&
make

Si vous avez installé Doxygen-1.8.19 (on peut aussi utiliser Graphviz-2.44.1) et si vous souhaitez créer la documentation de l'API, lancez :

make docs

Rappelez-vous la remarque avant configure. Pour tester les résultats, tapez : make check.

Maintenant, en tant qu'utilisateur root :

make install &&
mkdir -pv /usr/share/doc/pidgin-2.14.1 &&
cp -v README doc/gtkrc-2.0 /usr/share/doc/pidgin-2.14.1

Si vous créez la documentation de l'API, installez-la en utilisant les commandes suivantes en tant qu'utilisateur root :

mkdir -pv /usr/share/doc/pidgin-2.14.1/api &&
cp -v doc/html/* /usr/share/doc/pidgin-2.14.1/api
[Note]

Note

Ce paquet installe des fichiers d'icônes dans la hiérarchie /usr/share/icons/hicolor et des fichiers du bureau dans la hiérarchie /usr/share/applications. Vous pouvez améliorer les performances du système et l'utilisation de la mémoire en mettant à jour /usr/share/icons/hicolor/index.theme et /usr/share/applications/mimeinfo.cache. Pour réaliser la mise à jour vous devez avoir installé GTK+-2.24.32 ou GTK+-3.24.22 (pour le cache des icônes) et desktop-file-utils-0.26 (pour le cache du bureau) et taper la commande suivante en tant qu'utilisateur root :

gtk-update-icon-cache -qtf /usr/share/icons/hicolor &&
update-desktop-database -q

Explication des commandes

--disable-gstreamer : ce paramètre désactive la prise en charge de gstreamer parce qu'il y a des problèmes avec la construction lorsque la prise en charge de la voix et de la vidéo sont désactivé, mais gstreamer activé.

--disable-avahi : Supprimez ce paramètre si vous avez installé Avahi-0.8.

--disable-gtkspell : supprimez ce paramètre si vous avez installé Gtkspell et souhaitez activer la prise en charge du vérificateur d'orthographe.

--disable-meanwhile : Supprimez ce paramètre si vous avez installé Meanwhile.

--disable-idn : Supprimez ce paramètre si vous avez installé libidn-1.36.

--disable-nm : Supprimez ce paramètre si vous avez installé NetworkManager-1.26.0.

--disable-vv : supprimez ce paramètre si vous avez installé Farstream (Version 0.1) et souhaitez activer la prise en charge des communications audio et vidéo. Vous devriez supprimer le drapeau --disable-gstreamer.

--enable-cyrus-sasl : Supprimez ce paramètre si vous avez installé Cyrus SASL-2.1.27 et souhaitez construire Pidgin avec le support de SASL.

--disable-gnutls : Supprimez ce paramètre si vous avez installé GnuTLS-3.6.14 et NSS-3.55, mais souhaitez utiliser NSS-3.55 pour le support de SSL.

Configuration de Pidgin

Fichiers de configuration

~/.purple/* et ~/.gtkrc-2.0

Informations sur la configuration

La plupart de la configuration peut se faire en utilisant les divers paramètres de préférences dans les programmes. Vous pouvez créer aussi un fichier ~/.gtkrc-2.0 qui stocke les réglages des thèmes Gtk+-2 touchant l'application Pidgin et les autres applications Gtk+-2. Remarquez qu'un fichier exemple gtkrc-2.0 a été installé lors de l'installation du paquet et il peut être utilisé comme point de départ ou de référence.

Contenu

Programmes installés: pidgin, purple-client-example, purple-remote, purple-send, purple-send-async et purple-url-handler
Bibliothèque installée: libpurple.so, et libpurple-client.so
Répertoires installés: /usr/include/libpurple, /usr/include/pidgin, /usr/lib/pidgin, /usr/lib/purple-2, /usr/share/doc/pidgin-2.14.1, /usr/share/pixmaps/pidgin, /usr/share/purple et /usr/share/sounds/purple

Descriptions courtes

pidgin

est un client de messagerie instantanée basé sur GTK+ 2

purple-client-example

est un exemple qui montre comment utiliser libpurple-client pour communiquer avec purple.

purple-remote

envoi des commandes à distance à Pidgin/Finch.

purple-send

appelle les fonctions de l'API de purple avec DBus et affiche la valeur de retour.

purple-send-async

appelle les fonctions de l'API de purple avec DBus. Contairement à purple-send, il n'affiche pas la valeur de retour.

purple-url-handler

est un script python qui manipule des URL avec purple.

Last updated on 2020-06-23 20:19:22 +0000