gst-plugins-ugly-1.16.2

Introduction à GStreamer Ugly Plug-ins

GStreamer Ugly Plug-ins est un ensemble de greffons considéré par les développeurs de GStreamer comme étant de bonne qualité et fonctionnant correctement, mais leur distribution peut poser problèmes. La licence des greffons ou des bibliothèques supportés peut ne pas être comme les développeurs de GStreamer le voudraient. Le code peut être connu pour présenter des problèmes de brevets.

Ce paquet est connu pour se construire correctement sur une plateforme LFS-9.1.

Informations sur le paquet

Dépendances de GStreamer Ugly Plug-ins

Requises

gst-plugins-base-1.16.2

Recommandées

Facultatives

GTK-Doc-1.32, libmpeg2-0.5.1, libcdio-2.1.0 (pour l'accès aux lecteurs CD-ROM), Valgrind-3.16.1, libsidplay, OpenCore AMR, Orc et TwoLame

Notes utilisateur : http://wiki.linuxfromscratch.org/blfs/wiki/gst10-plugins-ugly

Installation de GStreamer Ugly Plug-ins

[Note]

Note

Si vous n'avez pas installé de compilateur Objective-C, le système de construction de ce paquet affichera un avertissement à propos d'une vérification échouée. C'est sans danger et vous pouvez continuer.

[Note]

Note

Si vous avez besoin d'un greffon pour une dépendance donnée, cette dépendance doit être installée avant ce paquet.

Installez GStreamer Ugly Plug-ins en lançant les commandes suivantes :

mkdir build &&
cd    build &&

meson  --prefix=/usr       \
       -Dbuildtype=release \
       -Dpackage-origin=http://www.linuxfromscratch.org/blfs/view/svn/ \
       -Dpackage-name="GStreamer 1.16.2 BLFS" &&
ninja

Pour tester les résultats lancez : ninja test.

Maintenant, en tant qu'utilisateur root :

ninja install

Contenu

Programmes installés: Aucun
Bibliothèques installées: Plusieurs greffons dans /usr/lib/gstreamer-1.0
Répertoires installés: /usr/share/gstreamer-1.0/presets et /usr/share/gtk-doc/html/gst-plugins-ugly-plugins-1.0

Last updated on 2020-02-18 22:50:03 +0000