cups-filters-1.27.5

Introduction à CUPS Filters

Le paquet CUPS Filters contient les moteurs, les filtres et d'autres logiciels qui faisaient partie autrefois de la distribution cœur de CUPS, mais qui ne sont plus maintenus par Apple Inc.

Ce paquet est connu pour se construire correctement sur une plateforme LFS-9.1.

Informations sur le paquet

  • Téléchargement (HTTP) : https://www.openprinting.org/download/cups-filters/cups-filters-1.27.5.tar.xz

  • Téléchargement (FTP) :

  • Somme de contrôle MD5 du téléchargement : 765bc236257811864fa19736417add59

  • Taille du téléchargement : 1.4 Mo

  • Estimation de l'espace disque requis : 48 Mo (avec les tests), 15 Mo installés

  • Estimation du temps de construction : 0.4 SBU (avec les tests)

Dépendances de CUPS Filters

Requises

Cups-2.3.3, GLib-2.64.4, ghostscript-9.52, Little CMS-2.11, Poppler-20.08.0 et Qpdf-10.0.1

Recommandées

Facultatives

Avahi-0.8 (requis pour construire le moteur DNSSD du démon cups-browsed, qui est requis pour utiliser certaines imprimantes en réseau), OpenLDAP-2.4.50, PHP-7.4.8 (l'utilisation est peut-être cassée), Liblouis (Braille) et Liblouisutdml (Braille)

Pilotes d'impression facultatifs (à l'exécution)

Gutenprint-5.3.3 (pour les imprimantes supportées) ou d'autres pilotes d'impression comme hplip

Notes utilisateur : http://wiki.linuxfromscratch.org/blfs/wiki/cups-filters

Installation de CUPS Filters

Installez CUPS Filters en lançant les commandes suivantes :

./configure --prefix=/usr        \
            --sysconfdir=/etc    \
            --localstatedir=/var \
            --without-rcdir      \
            --disable-static     \
            --disable-avahi      \
            --docdir=/usr/share/doc/cups-filters-1.27.5 &&
make

Pour tester les résultats lancez : make check. Les polices DejaVu sont requises pour les tests.

Maintenant, en tant qu'utilisateur root :

make install

Explication des commandes

--disable-avahi  : ce paramètre est nécessaire si le paquet facultatif Avahi-0.8 n'est pas installé. Supprimez-le si avahi est installé et que vous avez besoin des capacités de découverte d'imprimantes réseaux.

--without-rcdir : Ce paramètre désactive l'installation du script de démarrage inclut qui n'est pas compatible avec BLFS.

--disable-static : Ce paramètre empêche l'installation des versions statiques des bibliothèques.

--with-test-font-path=VALUE : Si vous souhaitez lancer les tests, mais n'avez pas la police /usr/share/fonts/dejavu/DejaVuSans.ttf par défaut, utilisez ce paramètre pour spécifier où DejaVuSans.ttf (ou éventuellement une autre police TTF - non testé) se trouve.

Contenu

Programmes installés: cups-browsed, driverless (lien), foomatic-rip (lien) et ttfread
Bibliothèques installées: libcupsfilters.so et libfontembed.so
Répertoires installés: /usr/include/{cupsfilters,fontembed}, /usr/lib/cups/driver, /usr/share/cups/{braille,charsets}, /usr/share/doc/cups-filters-1.27.5 et /usr/share/ppd/cupsfilters

Descriptions courtes

cups-browsed

est un démon pour naviguer les files CUPS et Bonjour d'imprimantes CUPS distantes et partagées.

foomatic-rip

est une enveloppe universelle de filtre d'affichage RIP qui peut être utilisée comme filtre CUPS ou seule pour l'impression directe sans spooler.

libcupsfilters.so

contient les fonctions de l'API de CUPS Filters.

Last updated on 2020-06-16 17:12:33 +0000